
Course Project — Design Optimization 
 
Introduction 
 
Design optimization is a technique that seeks to determine an optimum design. By "optimum 
design”, we mean one that meets all specified requirements but with a minimum expense of 
certain factors such as weight, surface area, volume, stress, cost, etc. In other words, the optimum 
design is usually one that is as effective as possible. 
 
Virtually any aspect of your design can be optimized: dimensions (such as thickness), shape (such 
as fillet radii), placement of supports, cost of fabrication, natural frequency, material property, 
and so on. During the optimization analysis, the program performs a series of analysis-evaluation-
modification cycles. That is, an analysis of the initial design is performed, the results are 
evaluated against specified design criteria, and the design is modified as necessary. This process 
is repeated until all specified criteria are met. 
 
The following terminology is used in connection with design optimization: 

 
• Design Variables (DVs) are independent quantities that are varied in order to  
achieve the optimum design. Up to 60 DVs may be defined in an ANSYS design 
optimization problem. Ansys requires a suitable range for each design variable.  
 

• State Variables (SVs) are quantities that are used to define constraints for the design. 
They are also known as dependent variables and are typically response quantities such as 
stresses and displacements. You may define up to 100 SVs in an ANSYS design 
optimization problem. A suitable range must be defined for each state variable.  

 
• Objective Function is the dependent variable that you are attempting to minimize. It 
should be a function of the DVs, i.e., changing the value of the DVs should change the 
value of the objective function. You can define only one objective function in an ANSYS 
design optimization problem.  
 

 
In ANSYS, the procedure for design optimization consists of the following main steps: 

1. Create an analysis file (i.e., a log or a lgw file) to be used during optimization loops. 
Remember that there are two log files created by ANSYS, one with extension .log, and 
the other with extension .lgw. The latter is an abbreviated version of the former, and is 
created upon request. The file should represent a complete analysis, and must contain the 
following steps: 

a. Build the model parametrically (PREP7), 
b. Obtain the solution (SOLUTION), 
c. Retrieve and assign to parameters the response quantities that will be used as state 
variables and objective function (POST1)  



2. Initialize the optimization analysis. 
a. Enter OPT and specify the analysis file (OPT). 
b. Declare optimization variables (OPT) 
c. Choose optimization method (OPT) 
d. Specify optimization looping controls (OPT) 

3. Carry out the optimization loop (OPT) 

4. Review the resulting design sets data (OPT) and post-process results (POST1)  
 
Example 
 
Find the minimum-weight (i.e., minimum volume) design of the truss structure shown in figure. 
Treat the cross-sectional area as the design variable and subject the model to the following 
constraints: 

• Stress s in any member should in be the range -20000 < s < 10000 
• Vertical deflection should not exceed 0.05  
• Cross sectional area should be in the range 0.25 < A < 2.5. 
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In this problem, the design variable is the cross sectional area, the state variables are the 
maximum displacements (d) and the axial stresses (s) in the truss system. The total 
volume of all elements is the objective function to be minimized. 
 
1. Build the model parametrically and initialize design variables 
 
The quantities used for DVs and SVs must be assigned an alphanumeric label and their values 
initialized using the Parameters menu. The parameters for design variables are defined at the 
beginning of the model creation. The design variables must be initialized, the initial values can be 
specified arbitrarily, as far as they are within the acceptable range. The parameters for SVs will 
be created in the postprocessor after solving the model. 
In this example, area of cross-section is the only design variable. Thus only one parameter called 
AREA is defined here. Later in the input all reference to parameter should be through its name. 

• ANSYS Utility Menu > Parameters > Scalar Parameters > Selection [ AREA=0.6 ] 
• Parameters > Save Parameters > OK 
• ANSYS Toolbar > SAVE_DB 



If we wanted to use different sections for different members in the truss, we could use several 
parameters, say AREA1, AREA2, etc. While defining real constants, then we would refer to the 
appropriate parameters. 
 

2. Define the element type (LINK1) and material properties.  
• Preprocessor > Element Type > Add/Edit/Delete > Add > Structure Link > [ 2D spar 1] 
• Preprocessor > Real Constants > Add/Edit/Delete > Add > Real Constant Set No.[1] >  
  Cross Sec Area [ AREA ] 
• Preprocessor > Material Props > Material Models > Structural > Linear  
 Elastic > Isotropic > > EX [ 30E6 ] > PRXY [0.3] 
 

3. Begin the model creation.  
• Preprocessor > -Modeling- Create 

Nodes > In Active CS 
NODE [ 1 ]  X,Y,Z [ 6 ] [ 0 ] [ 0 ] > Apply  
NODE [ 2 ]  X,Y,Z [ 18 ] [ 0 ] [ 0 ] > Apply 
NODE [ 3 ]  X,Y,Z [ 0 ] [ 8 ] [ 0 ]  >Apply 
NODE [ 4 ]  X,Y,Z [ 12 ] [ 8 ] [ 0 ]  >Apply 
NODE [ 5 ]  X,Y,Z [ 24 ] [ 8 ] [ 0 ]  >OK 

• Preprocessor > -Modeling- Create 
Elements > -Auto Numbered- Thru Nodes + 
[ Node 1 and 2] > Apply 
[ Node 1 and 3] > Apply 
[ Node 1 and 4] > Apply 
[ Node 2 and 4] > Apply 
[ Node 2 and 5] > Apply 
[ Node 3 and 4] > Apply 
[ Node 4 and 5] > OK 
 

4. Apply boundary conditions and loading. 
• Solution > -Define Loads- Apply > -Structural- Displacements > On nodes 

 
[ Node 5]: All dof 
[ Node 2]: UY 
 

• Solution > -Define Loads- Apply > -Structural- Force/Moments > On nodes 
 

• Apply loads  
[  Node 4]: [ FY ] > VALUE [ -1000 ]  
[  Node 3]: [ FY ] > VALUE [ -2000 ]  

 
5. Initiate the solution 
• Solution > -Solve- Current LS 
 

6. Retrieve results parametrically in the postprocessor.  
This is where you retrieve results data and assign them to parameters. ANSYS provides a number 
of commands that allows us to retrieve the value of selected variables, to pick out the 
maximum/minimum value from a pre-selected result array, and so on. At the end of an 



optimization loops, the state variables are evaluated, and the design variable are reset to continue 
the analysis.    
Important Note: Follow the steps below very carefully. Make sure to click on options in the 
dialog boxes even if they appear already selected. If you don't do this Ansys sometimes does not 
create a proper LGW file needed for optimization. 
 
• General Postproc > Read Result > Last Set  
 
We sort nodes based on absolute value of UY deflection. 
• General Postproc > List Results > -Sorted Listing- Sort Nodes... > KABS [ Yes ]  

Item, Comp [ DOF solution ] [ Translation UY ] > OK 
 

We now define a parameter DMAX = maximum absolute UY deflection 
• ANSYS Utility Menu > Parameters >  

Get Scalar Data > [ Result data ] [ Other operations ] > OK 
Name of parameter to be defined [ DMAX ]  
Data to be retrieved [ From sort oper'n ] [ Maximum value ] > OK 

 
Next we set-up element table to extract volume and axial stress for each element. The command VOLU is 
needed to get the element volume and LS, 1 is needed to get element stress. The labels AXIAL and VOL 
are user-specified names for the element volume and axial stress. 
• General Postproc > Element Table > Define Table > Add... > Lab [ VOL]  

[ Geometry ] [ Elem volume VOLU ] > OK > Close 
• General Postproc > Element Table > Sum of Each Item > OK 
• General Postproc > Element Table > Define Table > Add... >  

Lab [AXIAL] [By sequence num] [ LS ]> Selection [LS, 1] > OK > Close 
 
Now we can use the element table data to create three remaining SVs, VOLUME = total volume of 
elements, SMAX = maximum axial stress and SMIN= minimum axial stress. For volume we need to 
choose element table sums so that we can get total volume of the truss and use it in defining the objective 
function. 
• Parameters > Get Scalar Data > [ Result data ] [ Elem table sums ] > OK >Name of parameter to be 
defined [ VOLUME ] Element table item [ VOL ] > OK 
 
• General Postproc > List Results > -Sorted Listing- Sort Elems... > KABS [ no ]  

Item, Comp [ AXIAL ] > OK 
• Parameters > Get Scalar Data > [ Result data ] [ Other operations ] > OK >Name of parameter to be 
defined [ SMAX ] Data to be retrieved [ From sort oper'n ] [ Maximum value ] > Apply 
                                                      [ Result data ] [ Other operations ] > OK >Name of parameter to be 
defined [ SMIN ] Data to be retrieved [ From sort oper'n ] [ Minimum value ] > OK 
 
7. Create the analysis file -- Important Step! 
 
The following command creates a file (jobname.lgw) that represents the model database. This file 
contains all commands that were used to create the current database. Ansys will use this file repeatedly 
during optimization iterations. Therefore it is important to make sure that this file is free of any errors.  
• ANSYS Utility Menu > File > write DB Log File > OK 
 

8. Initiate optimization analysis 
 



Assign the jobname.LGW as the optimization analysis file. 
• Design Opt > -Analysis File- Assign..> jobname.lgw > OK 
 
Choose design and state variables from the list of parameters created earlier and define 
appropriate ranges. 
• Design Opt > Design Variables... > Add...  

>  AREA    MIN [ 0.25 ] MAX [ 2.5 ] > OK > Close 
• Design Opt > State Variables... > Add...  

>  DMAX    MIN [ 0 ] MAX [ 0.05 ] > Apply 

>  SMAX    MIN [ -20000 ] MAX [ 10000 ] > Apply  

>  SMIN    MIN [ -20000 ] MAX [ 10000 ] > OK > Close 
 
Choose objective function from the list of parameters created earlier. 

• Design Opt > Objective... >  VOLUME > OK 
 
Choose an optimization method. Select the maximum number of iterations. 

• Design Opt > Method/Tool... > MNAME [ Sub-Problem ] > OK 
> NITR [ 30 ] NINFS [ 7 ] > OK 

 
Note. ANSYS offers two optimization methods: the sub-problem approximation method and the 
first order method. The first method essential sweeps through the values of the design variables in 
the ranges and select the optimal design. The second involves more sophisticated mathematical 
tool (e.g., sensitivity analysis). In either case, the solution is obtained through a number of 
iterations.  
 
Start the optimization iterations 
• Design Opt > Run... > Begin Execution of Run > OK 
 
Ansys will stop if it finds an optimum or if the number of iterations reaches the specified 
maximum. Once the loop terminates, we can then review results and decide whether further 
iterations if needed. There are options for plotting history of objective function and other 
parameters as function of number of iterations. 
 
• Design Opt > -Design Sets-  List...> OK 

• Design Opt > -Design Sets-  Graphs/Tables > [XVAROPT ]  Set number 

NVAR  VOLUME > OK 



Project: Design Optimization 
 
An office furniture company is designing a new low cost chair. The basic concept calls for two 
upholstered cushions over sturdy plywood boards that are supported by two Z-shpaed frames. 
Your assignment is to come up with the lowest cost design for the frame while meeting the 
following requirements: 

a. The frames must be able to support a weight of 300 lb from the seat. 
b. To simulate the forces from a person sitting while leaning against the back, the frames 

must be able to support a vertical load of 250 lb from the seat and horizontal load of 50 lb 
form the back. 

c. Any part of the frame should not deflect more than 1/8 in. 
d. The factor of safety against stress failure should be at least 3. 

 

 
 
 
1. Consider the frame to be made of 2 in diameter steel tube with wall thickness 0.25 in. Model 
the frame with beam elements, create a finite element mesh that contains few tens of elements. 
Determine if the given design meets the stress and the deflection constraints. For simplicity, 
assume the loads exerted from the plywood boards are uniformly distributed. What is the weight 
of the frame in this design?  
 
2. Use design optimization capability of ANSYS to obtain a minimum weight design. For ease in 
manufacturing the same diameter must be used for the entire frame. However, the wall-thickness 
can be different for various part of the frame.  Don’t consider the weight of the plywood boards.    
 
Use the following material parameters: 61030×=E lb/in2, failure stress 60000=yσ  lb/in2 and 

weight density 256.0=ρ  lb/in3. 
   


